Jump to content

CopyFitLine Rule


Recommended Posts

Since upgrading to FP11 on Mac 10.15.3 I seem to get a unusual message when composing jobs if I have used a CopyFitLine rule.


The amount of text inserted into a flow exceeds the depth

of all frames in the flow <>. Text is truncated.

Text does not fit in the last frame on page 0 at (0 in, 0 in).


The job I noticed it on does have text that may need scaling and if you remove the copyfitline rule it works. I was told it could be related to the frames copyfit rule but even removing that doesn't stop the message. When composing it hasn't had an effect on the output file. Same file in FP10 had no issues.


To test I have made a very simple file (attached) with a large text frame and a single record that fits into the frame. When I apply a copyfitline rule I still get the message even though the text has had to fit.


I haven't tried under Windows but wonder if it is something I'm doing in the rule or a Mac related issue?

VDP Test.zip

Link to comment
Share on other sites

I don't get that message with FP 11.0.9 on macOS 10.14. I can try on a 10.15 machine later.


EDIT: I am able to reproduce this on macOS 10.14. I've entered a bug report.


You might consider using the "better" CopyfitLineWithMagnifyTag function instead:



You should also consider checking the "Re-evaluate this rule for every text flow" box and passing FusionPro.Composition.CurrentFlow.GetFrame().GetSettableTextWidth() as the width instead of hard-coding it.


Or, don't use a rule at all. Instead, turn on full-flow copyfitting (in the Overflow Options dialog) and, for the line in question, go to the Paragraph Settings and check "Do not break on Copyfit."

Edited by Dan Korn
Link to comment
Share on other sites



I have a template that uses the CopyFit line function on a text frame, and I get that same error when composing locally on my mac. But if I use Producer, I do not get the message. The job composes just fine, either way.


I do not get this error message if I am just using the generic copy fitting on text frames that is activated from the "overflow..." menu.


I am running 11.0.9 on Mac OS 10.14.5, Acrobat DC 2020

Link to comment
Share on other sites

  • 8 months later...
  • 2 weeks later...
  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...