Jump to content

Font not loading in new version 11.0.2


Recommended Posts

We recently upgraded to FusionPro VDP Designer 11.0.2 and now I'm having trouble loading a font I use every day. It's USPSIMBStandardMACps1 Postscript Type 1 font. I have loaded the font through Font Book and validated it. I have cleared my font caches. I have restarted my computer with no luck. I didn't have this issue with Direct 10. I can see the font through Acrobat DC but not FusionPro. I checked the font.err report and it says "Unsupported Mac resource fork font (suitcase): “/Users/******/Library/Fonts/USPSIMBStandardMACps1”, but a lot of other fonts say that also. Any ideas to help solve this loading issue that I haven't tried?



Mac OSX 10.14.5

FusionPro VDP Producer Direct 11.0.2 (Server)

FusionPro VDP Designer 11.0.2

Link to comment
Share on other sites

Upon further research, I loaded a different version (truetype) and got it to load but when I tried to select it in text editor Lucida Grande loaded. I then went to FusionPro: Advanced: and replaced Lucida Grande with the UPSPIMBStandard.ttf and it worked.

I believe this may be a bug in the new version of FusionPro that may need to be looked at. I never got the Postscript Version to load at all.

Link to comment
Share on other sites

Thank you for the feedback on FusionPro VDP 11. I'm sorry that you're having some trouble with it.


First, let me assure you that we are actively looking into all of the issues enumerated here.


With the major re-architecting we did to completely port the product to 64-bit and away from some of the older Mac APIs we had been using, we did expect a few minor changes in font handling on Mac. Unfortunately, you seem to have stumbled upon a couple of these right off the bat.


I feel compelled to reiterate what my signature says, which is that all font and installation issues should be directed to Support. And I see that you indeed did contact Support, which is great. But posting font-specific questions here on the forum is unlikely to yield any help from fellow FusionPro users in this community, as they likely don't have access to your fonts.


That said, there are a couple of generic issues that you bring up here, which may not actually be specific to your particular fonts, and I'm happy to address them.


As far as I can tell, there are three issues here:

  1. Some older resource-fork fonts no longer load in FusionPro.
  2. Some symbol fonts load, but then don't work as expected in the Text Editor.
  3. Some styles of fonts in certain font families can't be accessed.

I'll address each of these, as well as I can.




Some older resource-fork fonts no longer load in FusionPro.


There are some obsolete Mac-specific font formats which we are, unfortunately, no longer able to support in a modern Mac app. Many of these, such as resource fork fonts, date back to the Classic era of Macintosh, way before OS X, and even before OS 9. Such fonts are problematic in file share systems, and have no possibility of working on Windows, so their utility in any system utilizing FusionPro Producer or Server, or even sharing VDP templates across platforms, is negligible.


We highly recommend replacing any old resource-fork fonts with True Type (TTF), Open Type (OTF), True Type Collection (TTC), or even Data Font (.dfont) fonts, all of which are supported.




Some symbol fonts load, but then don't work as expected in the Text Editor.


This seems to be an issue with fonts which have a limited number of glyphs, such as symbol and barcode fonts. Interestingly, this affects not just our Text Editor, but other Mac apps as well, including Apple's own TextEdit app.


In this particular case, you're trying to take a font which literally only has four glyphs in it, for the four characters F, A, D, and T (the "full", "ascender", "descender", and "tracker" bar "states" in the four-state IMB barcode), and apply it to some text such as «barcode» in the Text Editor. But the problem is more general than that.


If I try to select some arbitrary text in our Text Editor or the TextEdit app, and apply a font such as Symbol or Webdings or USPSIMBStandard to it, it doesn't "take." However, if I type some characters that are actually represented with glyphs in the font, such as the string "FADT" and apply USPSIMBStandard to it, it works, in both editors.


Similarly, if I type or copy some text, in say, Japanese, into TextEdit, select it, then try to change to a font that doesn't support Japanese, TextEdit won't let me do that either. It's another aspect of the same problem.


What's going on is that the Mac text control is saying, "Hey, user, you can't apply a font to these characters that the font doesn't support." And, from the perspective of the control, this does make sense.


To a large extent, this is just The Way Fonts Work . You can't just say, "Here's any arbitrary Unicode character, now render it in this particular font," because not every font supports every character.


However, this is obviously a problem for variable data. If you want to try to let an end user type any arbitrary text into a form, put that text into a data files, and then typeset it, it's hard to do that in a way that supports anything in the world that the user might type, in any language or script, like Japanese, Thai/Devanagari, Cyrillic, etc. This is something that's hard to do in any variable data application, not just FusionPro.


Frankly, even if you could apply the barcode font to the barcode variable in the Text Editor, it's not going to look like much, and when you open up the editor again, it's not going to be obvious what that bit of text is doing. A better solution is to make a rule to return the barcode data in the correct font. You can use the built-in "Intelligent Mail Barcode Rule" in FusionPro, and it should work if you just specify the field with the barcode data in the first drop-down. Or, you can write a simple rule that looks something like this:

return '<f name="USPSIMBStandard">' + Field("IMB_data");


return '<f name="IDAutomation4State">' + Field("IMB_data");

But again, you should be able to use the "Intelligent Mail Barcode Rule" template rule, without needing any JavaScript.




Some styles of fonts in certain font families can't be accessed.


Historically, there are two ways to approach fonts and styles, and the entire computer industry has been split for a long time.


FusionPro has always worked with font families, rather than individual font styles or faces. This gives you the ability to use markup tags such as <b> and <i> (or the corresponding buttons in the Text Editor) to take text and make it into a bold or italic style, regardless of the font family in use (as long as the family supports those styles). So, we only present actual font families in the list in the Text Editor. These are the same font families shown in the Font Book app.


Because we use this family-based system of accessing fonts, you are generally limited to just four styles of each family (regular/normal, bold, italic, and bold + italic). There are font families with more than four styles, but FusionPro only allows access to the basic four faces; this is the case for the Helvetica font installed on macOS, among others.


This is how things have always worked in FusionPro. That said, in older versions of FusionPro on Mac, you may have actually seen the Quick Draw name of a font, and in some cases, Quick Draw split up certain families of fonts into multiple "faux" families. But there's no facility for accessing those older Quick Draw names in a modern 64-bit Mac app, and it's unfortunate that it presents as a regression in this particular case. Some fonts will still present as multiple families, such as the separate "Arial Black" variation of Arial.


We do have a long-term plan to change the way that FusionPro handles fonts, to allow the user to select any arbitrary named style of a font, similar to what programs like Adobe InDesign do, instead of just offering the four base styles. However, this is obviously a pretty big paradigm shift for the product, and we also need to still support older jobs which use family names and <b> and <i> tags. We will probably need a hybrid approach, such as you see in Microsoft Word; and in Word, you can also see that the hybrid approach has some issues. At any rate, while this change to the basic way that fonts work in FusionPro is on our roadmap, it's not something that we can rush.


There is a workaround in FusionPro 11, with markup tags: Now, in addition to specifying a font family name in a tag such as <f name="Helvetica">, you can specify a PostScript name, such as <f name="Helvetica-Light">. You can find out the PostScript name of any font style in the Font Book app on Mac by selecting it and doing Get Info. (Windows makes this harder to find; let me know if you want some tips.) So this is a way you can access those font styles. However, please note that this is not documented functionality, so you may encounter problems if you try to, say, collect the job for use in a FusionPro Producer or Server system.




So, to sum up what has become a very long post, we are still looking into these issues, though I'm not sure I have any immediate suggestions beyond these:

  1. Replace old resource fork fonts with newer versions.
  2. Use rules or tags to call out barcode fonts instead of using them directly in the Text Editor.
  3. Use alternate versions of fonts, or specify PostScript names in markup tags, to access styles such as Light.


Support may also respond to you with more specific information. We are investigating a way to modify the USPS fonts to allow them to be used directly in the Text Editor, and we may send you something to try.


I hope this information is helpful, and I apologize again for the trouble.

Link to comment
Share on other sites

  • 3 months later...

I'm happy to announce that most of these issues have been addressed in the latest release: FusionPro VDP 11.0.8.




  • Some symbol fonts load, but then don't work as expected in the Text Editor.

In FusionPro 11.0.2 on Mac, some barcode and symbol fonts could not be applied to text and variables in the Text Editor. Now in 11.0.8, if you select a font that can't be applied to the selected text, you will be given the option to insert a variable that will accomplish the font change in the output.


  • Some styles of fonts in certain font families can't be accessed.

FusionPro 11.0.2 had limited ability to select fonts with styles other than normal, bold, italic, and bold italic, especially on Mac. A new algorithm has been implemented to allow all font variations to be selected in FusionPro 11.0.8.


Note that the situation with older resource-fork fonts no longer loading in FusionPro has not changed. We continue to recommend replacing any old resource-fork fonts with True Type (TTF), Open Type (OTF), True Type Collection (TTC), or even Data Font (.dfont) fonts, all of which are supported.


Thank you again for helping to bring these issues to our attention, and for your understanding.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...