Jump to content

Special Characters


Recommended Posts

I need my MAC for this particular job for font reasons and I can't get "Décor" to work correctly. It works fine on the PC. Is there something I'm missing?

Is this text in your input data file, in a rule, typed into a text frame, or from somewhere else?


If it's your input data file, you might need to set the encoding on the "Data Source - Flat File" step of the Define Data Source dialog.


If it's in a rule, you'll need to use entities as Eric describes. Or put the text into a Formatted Text Resource and call that out in the rule.


If it's in a text frame or a Formatted Text Resource, the encoding should get automatically converted.

Link to comment
Share on other sites

It is in my data file and I tried changing the encoding when defining the data with no luck changing it to all the different options available.

It could be a font issue. Are you using the same font on Windows and Mac? Are there any messages in the log file about fonts or encoding? Can you post a job which demonstrates the problem?

Link to comment
Share on other sites

Thanks Don. Setting the encoding to Mac Roman in the Data Source Wizard should work, but it's not. I'm investigating why that's not working now.


What I would do as a workaround is save the file as Unicode (UTF-16). That will surely work. That's also what I would use for all files going forward, as much as possible. It's not an 8-bit world anymore.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...