Jump to content

repeatRecordNumber stopped working


Recommended Posts

I have a puzzle. Occasionally, I have jobs that I utilize the repeat record count function in an "onRecordStart" rule, and I then print divider sheets between the records by utilizing the "onRecordEnd" rule listed below:



if (FusionPro.Composition.repeatRecordNumber == Field("number of records"))



FusionPro.Composition.SetBodyPageUsage("Divider", true)

FusionPro.Composition.SetBodyPageUsage("Divider2", true)



This has always worked, until now. The repeat record function is working, but the divider sheets won't print. This is the first time I've used this since upgrading to OS 10.5 several months ago. I have uninstalled FP Desktop 6.0P1f and reinstalled, even tried 6.1, but no luck. Is the OS the issue, or am I missing something else here?



Intel Mac

OS 10.5

FP Desktop 6.0P1f

FP Desktop 6.

Link to comment
Share on other sites

What value are you assigning to the repeatRecordNumber function prior to the IF statement? If it doesn't equal anything, I don't see how the IF statement can compare it to your field.


EDIT: I just re-read your OP and realized I erred in my response above. Your logic is that the repeatRecordNumber would be equal to the last iteration of the OnRecordStart assignment when it triggers the addition of the divider sheets. Nice idea, actually. If someone more intelligent than me responds with a fix, I might have to use this logic on some of my jobs as well. ;)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...