Jump to content

High Sierra and FP 10.0.16

Recommended Posts

NOTE: This is fixed in FusionPro 10.1. -- Dan Korn


I recently installed High Sierra and updated from the previous version to 10.0.16 using Acrobat DC 2017.012 and have been unable to compose an output using the same files and data from previous versions of OSX and FP, I keep getting the following error:


There was an error while reading a stream


When i open the composed PDF/VT or PDF file.


Please advise if there is a solution for this.

Edited by Dan Korn
Link to comment
Share on other sites

Hi Clifford,


Sorry that you're having trouble.


Let me first say that our testing with FusionPro 10.0.16 against macOS 10.13 "High Sierra" has not yet uncovered any new issues, and I know that others have been using that combination in the field for some time. However, we have NOT yet certified support for High Sierra, nor have we announced support for High Sierra on our downloads page.


That said, we do want to address this issue. Unfortunately, there's not enough information here to diagnose and isolate the problem and come up with a solution. At a minimum, the output file would need to be examined. The collected template would be better. You could send the files to Support if you can't post them here.


Some specific questions:

  • Does this problem occur with just one particular job, or set of jobs? Can you reproduce it with one of the installed tutorial jobs?
  • What were the previous versions of FusionPro and macOS where the job used to run?
  • What version of Acrobat are you running?

Edited by Dan Korn
Link to comment
Share on other sites

Thanks for addressing this.


I will send the collected files to support shortly.

Before updating I asked support if it is compatible with High Sierra and was told "Yes it is supported".


Answers to your questions:

It occurred with multiple jobs which we use regularly that contain FP Expressions images, once I remove the FP Expressions images the error does not occur.


I tried the frodo travel tutorial and did not get the error (and that has FP Expressions images)


I previously used the most current version before i upgraded.


I was able to complete the job today by using one of our systems which was still running OSX Sierra and no errors occurred.


I hope this additional info helps.

Link to comment
Share on other sites

Thank you. That's all helpful. I will ask Support to send me your files as soon as I get them.


I wonder if this is really an issue with FusionPro Expression. What version of that do you have installed?


I also wonder whether it's an issue with trying to create new Expression images, versus having them already created and cached from previous compositions. That might be why you don't have the problem with the Frodo Travel tutorial, since you probably already ran that with your older setup.


Also, since you upgraded both FusionPro VDP and macOS at the same time, I'm not sure we can isolate this as an issue specific to High Sierra. It could be an issue specific to the new version of FusionPro VDP you're running, or some other configuration issue. When you say, "I previously used the most current version before i upgraded," what version specifically was that?

Link to comment
Share on other sites

I got the files from Support. We're investigating now.


In addition to the questions from my previous post:

  • What version of FusionPro Expression do you have installed?
  • What specific version of FusionPro VDP did you have installed previously?

I have two others:

  • Can you please post or send the output which demonstrates the original issue, where the message "There was an error while reading a stream" appears when you open it?
  • What version of Acrobat are you running?



Link to comment
Share on other sites

The FP Expressions ver is 3.2 that is installed

The FP VDP ver was 10.0.3 that was on OSX Sierra before the upgrade to High Sierra

Acrobat Pro ver is 2017.012.20098 (the most current on Adobe CC)

Thanks for this information.

I will send the screenshot which has the error.

Thanks, but I need the actual PDF output file, not just a screenshot.

Link to comment
Share on other sites

Support contacted me and confirmed they tested the files I sent on High Sierra and Acrobat Pro and succeeded in composing the output file with no errors.


I formatted and did a clean install of High Sierra and only installed FP VDP, Expressions and Acrobat and used the same files I sent support and yourself, I got the same error.

Link to comment
Share on other sites

  • 9 months later...

I am running into a similar issue. My job is pulling variable image for each record. We do not have 'expression' .

When composing records 1-10, no error. When composiing record 10-20, no error. When composing records 1-20 - I get "error while reading stream" when opening the composed file.

I am using mac os 10.13.1

FusionPro® VDP Creator 10.0.26




If I compose the job on a mac running OS 10.12, there are no errors.



Have you come up with any solutions for using os 10.13? Do I need to reinstall FP?

Link to comment
Share on other sites

  • 5 weeks later...
This problem has been happening to me ever since I went to High Sierra. Using bother 10.0.16 and 10.0.26 I still get this issue, especially when composing files with 1000 pages or more. Has there been any resolution to this or do we need to roll back our OS just to run FP?
Link to comment
Share on other sites

You have to run 10.0.16, 10.0.26, and the beta 10.0.32 on a Mac whose operating system hard drive has not been converted to the APFS file system. High Sierra converts the file system to APFS by default. I was fortunate I was able to pull an old retired mac out of mothballs and install FP on it to get around this issue. Support says they are aware of the issue and are working on a fix, but they do not have an ETA for release.


With Apple and Adobe on the verge of releasing their next updates, we are on the verge of being two generations behind on compatibility. Then there's the impending issue of 32-bit compatibility coming to an end. I truly hope something is in the works and we can have it, soon.

Link to comment
Share on other sites

I can announce that we have a Beta build on Mac which fixes the problem with composing on the new Apple File System in High Sierra.


It's FusionPro VDP version 10.0.37. Please contact FusionProSupport@PTI.com to get a download link.


Anyone with a FusionPro 10 license can install it. However, MarcomCentral users may not yet be able to upload templates created with 10.0.37 to their MarcomCentral stores.


Thanks for everyone's patience while we investigated this and found a solution.


EDIT: This is also fixed in FusionPro 10.1.

Edited by Dan Korn
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...