Jump to content

Issue with Special Characters and Calibri on Mac


Recommended Posts

I don't know if anyone can help but if so, please let me know. I am trying to do addressing on letters for a customer and I have to use Calibri. Everything was fine until I got to addressing international letters and some of the special characters are defaulting to something else. I can manually go into the .csv file and change them and it works, but I've got over 1000 letters to do. I'm told that it's a Mac issue and the Calibri coding for those characters and that it should work on the PC but I don't have that capability. Does anyone know a workaround or a Calibri version that works? Thank You!
Link to comment
Share on other sites

Well, without the job files, it's hard to diagnose what's going on. So you could post the collected template here. (Please do not post proprietary font files here, though.)


A couple other things that might help: You could check, or un-check, the "Limit processing to MacRoman text" box on the Advanced tab of the Composition Settings and see if that makes a difference. Also, some improvements to font handling have been made in later versions of FusionPro, so you could try version 9.3 or 10.0. (Contact Sales for a trial license of version 10.)


Though frankly, I'll bet this is really an encoding problem, not a font problem per se. So the answer is probably just to select the proper encoding of the data file in the Data Source Wizard:



I suspect that the data file was created on Windows, and has Latin-1 encoding, but I can't be sure without seeing it.


The other solution is to save the file as Unicode, either UTF-8 or UTF-16, with a byte order mark. Unicode solves the ambiguity problem of the Tower of Babel of multiple 8-bit text encodings.


Edited by Dan Korn
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...