Jump to content

Superscript Register Symbol

Recommended Posts

I have been trying to make the register symbol from my data file superscript. I realized after a while that the font I was using was the problem so I tried using ReplaceSubstring to change the font of only the symbol but it still does not seem to be working. I found someone with a similar issue and tried modifying the code that worked for them, my modified version is below.


FieldContent = Field("Title")
return ReplaceSubstring(TaggedTextFromRaw(FieldContent), "®",
   "<f name=\"Adobe Garamond Pro\"><superscript>®</superscript></f>");

Link to comment
Share on other sites

  1. Are you actually using the variable with the name of the rule in your text frame?
  2. Look at the log file to make sure you don't have any warning messages about fonts.
  3. Try adding some debugging code to the rule, like so:
    Print("Title Field: " + Field("Title"));

    And look in the log file to see what it reports.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...