Jump to content

OnNewOutputFile error


Recommended Posts



We've recently upgraded from FP6.2 to 7.1. I have been using the same "OnNewOutputFile" rule for quite some time and now after upgrading it gets an error when composing. Nothing has changed with this template besides the upgrade. Can someone let me know what I need to change now to fix this. Thanks.


msg error


OnNewOutputFile, line 1: Error: In Field(), no data source defined or data could not be loaded.



Link to comment
Share on other sites

  • 2 weeks later...

That message can be safely ignored. As you have seen, your output file will still be properly named; you'll just get the false message once per composition. So it's a reporting bug, against which I've created case FP-11499.


I didn't see the problem when I tried it in the Frodo Travel tutorial, because that job does preprocessing for FP Expression images, and the preprocessing suppresses that message. Turning on imposition stacking will also invoke preprocessing and suppress the message.

Link to comment
Share on other sites

  • 1 month later...
I am running into the same error but no output file is produced.

This occurs when I turn on PDF security.

Sorry, that is a different bug, one about which I was not aware.


This bug doesn't have anything to do with the OnNewOutputFile rule. You'll get the same crash if you have the "Output to multiple files" box checked and you're using PDF Security, regardless of whether you're trying to rename the output file in OnNewOutputFile or doing preprocessing. Apparently that particular combination of features (output to multiple files with PDF security) is not covered in our QA testing.


I've entered case FP-11516 regarding this issue, and we'll make sure it gets fixed in the 7.2 release. (Actually, I've already fixed it.)


In the meantime, you'll have to either not use security or output to a single file. Or you can compose to a non-PDF-based output format (which ignores the PDF Security settings). If these workarounds are not acceptable, please contact Support and they will escalate the issue.

If I turn off PDF security, I get the same response as is written above.

That's just the aforementioned reporting bug (FP-11499), which is harmless, although that's targeted for a fix in 7.2 as well.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...