Go Back   MarcomCentral (PTI) and FusionPro User Communities > Software-Related Talk > The JavaScript Library

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old August 9th, 2011, 11:27 AM
mclisa81 mclisa81 is offline
Regular Contributor
 
Join Date: Oct 2008
Location: Manchester CT
Posts: 97
Default Help with on record start error.

Can anyone help me with the following rule that throws an error when composing. The output is fine, I would just like to get rid of the error so it doesn't confuse other operators. I have a 2 pg template that is controlled by the on record start rule below. The error is "No page is emitted, please check page usage in your input file". I believe it happens when the value of Field BMarks is 0. Thanks.

Code:
if (Field("BMarks")=="0")
{
	FusionPro.Composition.SetBodyPageUsage("Bookmarkfront", false)
    FusionPro.Composition.SetBodyPageUsage("Bookmarkback", false)


}
else

  FusionPro.Composition.repeatRecordCount = Field("BMarks");
Reply With Quote
  #2  
Old August 9th, 2011, 11:33 AM
Dan Korn's Avatar
Dan Korn Dan Korn is offline
FusionPro Senior Engineer / Forum Moderator
 
Join Date: Aug 2008
Location: Chicago, IL
Posts: 4,305
Default Re: Help with on record start error.

If there's really nothing to compose for the record when the number is zero, then instead of turning off all the pages, just skip the record completely, like so:
Code:
if (Field("BMarks")=="0")
    FusionPro.Composition.composeThisRecord = false;
else
    FusionPro.Composition.repeatRecordCount = Field("BMarks");
__________________
Dan Korn
FusionPro Developer / JavaScript Guru / Forum Moderator
PTI Marketing Technologies | Printable | MarcomCentral
LinkedIn

I am a not a Support engineer, and this forum is not a substitute for Support. My participation on this forum is primarily as a fellow user (and a forum moderator). I am happy to provide help and answers to questions when I can; however, there is no guarantee that I, or anyone else on this forum, will be able to answer all questions or fix any problems. If I ask for files to clarify an issue, I might not be able to look at them personally. I am not able to answer private messages, emails, or phone calls unless they go through proper Support channels. Please direct any sales or pricing questions to your salesperson or inquiries@marcom.com.

Complex template-building questions, as well as all installation and font questions or problems, should be directed to FusionProSupport@marcom.com. Paid consulting work may be required to fulfill your template-building needs.

This is a publicly viewable forum. Please DO NOT post fonts, or other proprietary content, to this forum. Also, please DO NOT post any "live" data with real names, addresses, or any other personal, private, or confidential data.

Please include the specific versions of FusionPro, Acrobat, and your operating system in any problem reports or help requests. I recommend putting this information in your forum signature. Please also check your composition log (.msg) file for relevant error or warning messages.

Please post questions specific to the MarcomCentral Enterprise and Web-to-Print applications in the MarcomCentral forum. Click here to request access. Or contact your Business Relationship Manager (BRM/CPM) for assistance.

Please direct any questions specific to EFI's Digital StoreFront (DSF) to EFI support.

How To Ask Questions The Smart Way

The correct spellings are JavaScript, FusionPro, and MarcomCentral (each with two capital letters and no spaces). Acceptable abbreviations are JS, FP, and MC (or MCC). There is no "S" at the end of "Expression" or "Printable"! The name of the product is FusionPro, not "Fusion". "Java" is not is not the same as JavaScript.

Check out the JavaScript Guide and JavaScript Reference! FusionPro 8.0 and newer use JavaScript 1.7. Older versions use JavaScript 1.5.

return "KbwbTdsjqu!spdlt\"".replace(/./g,function(w){return String.fromCharCode(w.charCodeAt()-1)});
Reply With Quote
  #3  
Old August 9th, 2011, 11:35 AM
mclisa81 mclisa81 is offline
Regular Contributor
 
Join Date: Oct 2008
Location: Manchester CT
Posts: 97
Default Re: Help with on record start error.

Great! Thanks for the quick reply Dan.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:56 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
(c) 2011, PTI Marketing Technologies™, Inc.