Go Back   MarcomCentral (PTI) and FusionPro User Communities > Support > Fonts

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old December 3rd, 2012, 02:23 PM
umakadar umakadar is offline
Junior Community Member
 
Join Date: Jul 2011
Posts: 20
Default with accented character

Hi,

I am using Fusion pro server 4.1pb1 on Windows server 2003
I have an exported tab delimited text file with UTF-8 encoding which has few asscented ń characters. When I open this text file in notepad it shows ń character, but when I open the text file in excel file, it shows as ñ and that is what it prints when I compose.

How do I make this character appear as it is? Please advise.

Thanks
Reply With Quote
  #2  
Old December 3rd, 2012, 02:44 PM
Alex Marshall's Avatar
Alex Marshall Alex Marshall is offline
FusionPro VDP Support
 
Join Date: Sep 2008
Location: Chicago,Illinois
Posts: 383
Default Re: with accented character

Hello,
You will need to upgrade to our most current version of Fusionpro for Unicode support, as it is not supported in Fusionpro version 4.
Reply With Quote
  #3  
Old December 4th, 2012, 08:27 AM
umakadar umakadar is offline
Junior Community Member
 
Join Date: Jul 2011
Posts: 20
Default Re: with accented character

Thanks for the update!
Reply With Quote
  #4  
Old August 26th, 2014, 09:09 AM
tbone56 tbone56 is offline
Junior Community Member
 
Join Date: Sep 2010
Posts: 29
Default Re: with accented character

Hello, I see this problem is from 2012 but I don't see a resolution besides upgrading. I'm having the same issues seeing the special character in Trē. I'm using Fusion Pro 9.1.0 and Adobe Acrobat 9.5.5.

The Data Source I'm using is a .CSV file. The ē displays properly in both Excel and the Preview Record Selector, but completely disappears in the actual adobe acrobat preview that it generates. Any ideas? Please let me know if you need any further information and thank you in advance for looking.
Reply With Quote
  #5  
Old August 26th, 2014, 09:42 AM
Alex Marshall's Avatar
Alex Marshall Alex Marshall is offline
FusionPro VDP Support
 
Join Date: Sep 2008
Location: Chicago,Illinois
Posts: 383
Default Re: with accented character

You need to ensure your data file is saved as Unicode or UTF-8.

Then enable the Unicode support by doing the following.

First open your data file in Notepad ora Text Editor.

Select File>>Save As.

In the area where it indicates “Encoding”, select “Unicode”.

In Fusionpro, Select “FusionPro>>Advanced>>Advanced Settings”

Check the box for “Enable Asian Character Support” and reload All fonts.

When linking the data file, you can use the default encoding settings in the data wizard or specify it in this dialog

Mac Roman or Latin-1.

You will also need to ensure that the font being used for the text, support the characters in the language.

A good font to test is the “Arial Unicode MS” against the data being used to ensure the text displays correctly.
Reply With Quote
  #6  
Old August 26th, 2014, 09:52 AM
tbone56 tbone56 is offline
Junior Community Member
 
Join Date: Sep 2010
Posts: 29
Default Re: with accented character

Thanks for that. I"m attempting to follow your steps, but after checking the box "Enable Asian Character Support" and clicking ok, I get this error:

Error creating registry key:
HKEY_LOCAL_MACHINE\Software\PTI\FusionPro\Paths
Reply With Quote
  #7  
Old August 26th, 2014, 09:56 AM
Dan Korn's Avatar
Dan Korn Dan Korn is offline
FusionPro Senior Engineer / Forum Moderator
 
Join Date: Aug 2008
Location: Chicago, IL
Posts: 4,408
Default Re: with accented character

Quote:
Originally Posted by tbone56 View Post
Thanks for that. I"m attempting to follow your steps, but after checking the box "Enable Asian Character Support" and clicking ok, I get this error:

Error creating registry key:
HKEY_LOCAL_MACHINE\Software\PTI\FusionPro\Paths
Please locate the configure.exe program in the FusionPro installation location, usually "C:\Program Files (x86)\PTI\FusionPro" on a 64-bit OS or "C:\Program Files\PTI\FusionPro" on a 32-bit OS. Right-click configure.exe and select "Run as administrator." Enter an admin user name and password if prompted. Then click "Advanced Settings" and you will be able to click "Enable Asian Character Support" and then OK without an error.
__________________
Dan Korn
FusionPro Developer / JavaScript Guru / Forum Moderator
PTI Marketing Technologies | Printable | MarcomCentral
LinkedIn

I am a not a Support engineer, and this forum is not a substitute for Support. My participation on this forum is primarily as a fellow user (and a forum moderator). I am happy to provide help and answers to questions when I can; however, there is no guarantee that I, or anyone else on this forum, will be able to answer all questions or fix any problems. If I ask for files to clarify an issue, I might not be able to look at them personally. I am not able to answer private messages, emails, or phone calls unless they go through proper Support channels. Please direct any sales or pricing questions to your salesperson or inquiries@marcom.com.

Complex template-building questions, as well as all installation and font questions or problems, should be directed to FusionProSupport@marcom.com. Paid consulting work may be required to fulfill your template-building needs.

This is a publicly viewable forum. Please DO NOT post fonts, or other proprietary content, to this forum. Also, please DO NOT post any "live" data with real names, addresses, or any other personal, private, or confidential data.

Please include the specific versions of FusionPro, Acrobat, and your operating system in any problem reports or help requests. I recommend putting this information in your forum signature. Please also check your composition log (.msg) file for relevant error or warning messages.

Please post questions specific to the MarcomCentral Enterprise and Web-to-Print applications in the MarcomCentral forum. Click here to request access. Or contact your Business Relationship Manager (BRM/CPM) for assistance.

Please direct any questions specific to EFI's Digital StoreFront (DSF) to EFI support.

How To Ask Questions The Smart Way

The correct spellings are JavaScript, FusionPro, and MarcomCentral (each with two capital letters and no spaces). Acceptable abbreviations are JS, FP, and MC (or MCC). There is no "S" at the end of "Expression" or "Printable"! The name of the product is FusionPro, not "Fusion". "Java" is not is not the same as JavaScript.

Check out the JavaScript Guide and JavaScript Reference! FusionPro 8.0 and newer use JavaScript 1.7. Older versions use JavaScript 1.5.

return "KbwbTdsjqu!spdlt\"".replace(/./g,function(w){return String.fromCharCode(w.charCodeAt()-1)});
Reply With Quote
  #8  
Old August 26th, 2014, 10:13 AM
tbone56 tbone56 is offline
Junior Community Member
 
Join Date: Sep 2010
Posts: 29
Default Re: with accented character

Quote:
Originally Posted by Alex Marshall View Post
You need to ensure your data file is saved as Unicode or UTF-8.

Then enable the Unicode support by doing the following.

First open your data file in Notepad ora Text Editor.

Select File>>Save As.

In the area where it indicates “Encoding”, select “Unicode”.

In Fusionpro, Select “FusionPro>>Advanced>>Advanced Settings”

Check the box for “Enable Asian Character Support” and reload All fonts.

When linking the data file, you can use the default encoding settings in the data wizard or specify it in this dialog

Mac Roman or Latin-1.

You will also need to ensure that the font being used for the text, support the characters in the language.

A good font to test is the “Arial Unicode MS” against the data being used to ensure the text displays correctly.
Thanks to Dan for helping with the Error in the previous post i had.

I have followed step for step but still get the same results. I've made sure that the .csv file was opened in notepad and saved with Unicode encoding, marked the asian character settings and have checked the data file loading was set to Latin -1. The character is still missing from adobe preview. Anything else I could be doing wrong?
Reply With Quote
  #9  
Old August 26th, 2014, 10:27 AM
Dan Korn's Avatar
Dan Korn Dan Korn is offline
FusionPro Senior Engineer / Forum Moderator
 
Join Date: Aug 2008
Location: Chicago, IL
Posts: 4,408
Default Re: with accented character

Quote:
Originally Posted by tbone56 View Post
I have followed step for step but still get the same results. I've made sure that the .csv file was opened in notepad and saved with Unicode encoding, marked the asian character settings and have checked the data file loading was set to Latin -1. The character is still missing from adobe preview. Anything else I could be doing wrong?
It's hard to tell what's going wrong just from Preview. You need to do a regular composition, not a Preview, and then click the View Log button, and there should be a relevant error or warning message there in the log (.msg) file.
__________________
Dan Korn
FusionPro Developer / JavaScript Guru / Forum Moderator
PTI Marketing Technologies | Printable | MarcomCentral
LinkedIn

I am a not a Support engineer, and this forum is not a substitute for Support. My participation on this forum is primarily as a fellow user (and a forum moderator). I am happy to provide help and answers to questions when I can; however, there is no guarantee that I, or anyone else on this forum, will be able to answer all questions or fix any problems. If I ask for files to clarify an issue, I might not be able to look at them personally. I am not able to answer private messages, emails, or phone calls unless they go through proper Support channels. Please direct any sales or pricing questions to your salesperson or inquiries@marcom.com.

Complex template-building questions, as well as all installation and font questions or problems, should be directed to FusionProSupport@marcom.com. Paid consulting work may be required to fulfill your template-building needs.

This is a publicly viewable forum. Please DO NOT post fonts, or other proprietary content, to this forum. Also, please DO NOT post any "live" data with real names, addresses, or any other personal, private, or confidential data.

Please include the specific versions of FusionPro, Acrobat, and your operating system in any problem reports or help requests. I recommend putting this information in your forum signature. Please also check your composition log (.msg) file for relevant error or warning messages.

Please post questions specific to the MarcomCentral Enterprise and Web-to-Print applications in the MarcomCentral forum. Click here to request access. Or contact your Business Relationship Manager (BRM/CPM) for assistance.

Please direct any questions specific to EFI's Digital StoreFront (DSF) to EFI support.

How To Ask Questions The Smart Way

The correct spellings are JavaScript, FusionPro, and MarcomCentral (each with two capital letters and no spaces). Acceptable abbreviations are JS, FP, and MC (or MCC). There is no "S" at the end of "Expression" or "Printable"! The name of the product is FusionPro, not "Fusion". "Java" is not is not the same as JavaScript.

Check out the JavaScript Guide and JavaScript Reference! FusionPro 8.0 and newer use JavaScript 1.7. Older versions use JavaScript 1.5.

return "KbwbTdsjqu!spdlt\"".replace(/./g,function(w){return String.fromCharCode(w.charCodeAt()-1)});
Reply With Quote
  #10  
Old August 26th, 2014, 10:32 AM
tbone56 tbone56 is offline
Junior Community Member
 
Join Date: Sep 2010
Posts: 29
Thumbs up Re: with accented character

Looks like it just wasn't showing in Preview, but did display on the composed file. I appreciate your time Alex and Dan! Problem solved.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:48 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
(c) 2011, PTI Marketing Technologies™, Inc.