Go Back   MarcomCentral (PTI) and FusionPro User Communities > Software-Related Talk > FusionPro® VDP Creator

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old August 23rd, 2012, 03:50 PM
Meir Meir is offline
Regular Contributor
 
Join Date: Mar 2011
Location: Lawrenceville, NJ
Posts: 50
Unhappy Font Wont Load

Hello,

I am trying to use font Futura Std Bold [file name 'FuturaStd-Bold.otf'].

I have this loaded in my system fonts.

When I try to use it in fusion pro, I can find it in the variable text editor, and it displays properly in the editor. It displays wrong in the preview, and when I compose the file, it appears correct, but tells me the font is not loaded it is instead using the italic version.

To try to solve this, I have loaded all fonts in acrobats fusion pro menu. I have tried loading all fonts in Fusion Pro. I have tried loading new fonts in Fusion Pro. I restarted both acrobat and fusion pro after each of these attempts. It still behaves the same.

I tried restarting my computer and retrying these efforts. I tried closing acrobat and loading fonts in fusion pro while acrobat was closed. No dice.

I tried uninstalling fusion pro and reinstalling it. No dice. I then tried to load all fonts again and it still wont work.

Has anyone else faced this issue? Is there a way to get it to work?
Is there any other way to get Fusion Pro to recognize the font?

Attached is an image comparing the Preview, the Variable Text Editor and Composed File.

I am using:
Acrobat 9.5.1
Fusion Pro Designer 7.2P1k
Mac OS X 10.5.8
Any and all help would be appreciated!
Thank you
Attached Files
File Type: pdf Why.pdf (251.0 KB, 14 views)
__________________
Meir Galimidi
Allegra
FP 7.2P1k, MAC OSX 10.5.8, Acrobat 9.4.0
Reply With Quote
  #2  
Old August 23rd, 2012, 04:09 PM
ThomasLewis's Avatar
ThomasLewis ThomasLewis is offline
Senior Contributor
 
Join Date: Feb 2011
Posts: 211
Default Re: Font Wont Load

On the PC there is a fonts.ini file that FusionPro uses to define bold/italic. Sometimes (particularly with fonts named "bold") the definitions are wrong and you have to fix the ini file. I have no idea how this translates on the mac or what that ini file would be. If there is any similarity you just need to tweak that file and restart Acrobat.

Example (on the PC):
Futura Std Book;FuturaStd-Bold;Bold;1;0;W;;OpenType PostScript;~~
Futura Std Book;FuturaStd-BoldOblique;Bold Italic;1;1;W;;OpenType PostScript;~~

You could change to:
Futura Std Bold;FuturaStd-Bold;Regular;0;0;W;;OpenType PostScript;~~
Futura Std Bold;FuturaStd-BoldOblique;Italic;0;1;W;;OpenType PostScript;~~
Reply With Quote
  #3  
Old August 23rd, 2012, 05:03 PM
Dan Korn's Avatar
Dan Korn Dan Korn is offline
FusionPro Senior Engineer / Forum Moderator
 
Join Date: Aug 2008
Location: Chicago, IL
Posts: 4,369
Default Re: Font Wont Load

In your screenshot, the font looks the same in the composed output as in the Variable Text Editor. So there's no issue with composition, despite the message in the log file. Please don't edit your fonts.ini file.

If a font is not showing up properly in Preview, then you need to turn on the "Use Local Fonts" setting in Acrobat. See this thread for more info:
http://forums.pti.com/showthread.php?t=404

To get to the setting in Acrobat 9 (or Acrobat X) on Mac, select "Acrobat -> Preferences" from the menu, then under Categories, select "Page Display", and check the "Use Local Fonts" box about halfway down.
__________________
Dan Korn
FusionPro Developer / JavaScript Guru / Forum Moderator
PTI Marketing Technologies | Printable | MarcomCentral
LinkedIn

I am a not a Support engineer, and this forum is not a substitute for Support. My participation on this forum is primarily as a fellow user (and a forum moderator). I am happy to provide help and answers to questions when I can; however, there is no guarantee that I, or anyone else on this forum, will be able to answer all questions or fix any problems. If I ask for files to clarify an issue, I might not be able to look at them personally. I am not able to answer private messages, emails, or phone calls unless they go through proper Support channels. Please direct any sales or pricing questions to your salesperson or inquiries@marcom.com.

Complex template-building questions, as well as all installation and font questions or problems, should be directed to FusionProSupport@marcom.com. Paid consulting work may be required to fulfill your template-building needs.

This is a publicly viewable forum. Please DO NOT post fonts, or other proprietary content, to this forum. Also, please DO NOT post any "live" data with real names, addresses, or any other personal, private, or confidential data.

Please include the specific versions of FusionPro, Acrobat, and your operating system in any problem reports or help requests. I recommend putting this information in your forum signature. Please also check your composition log (.msg) file for relevant error or warning messages.

Please post questions specific to the MarcomCentral Enterprise and Web-to-Print applications in the MarcomCentral forum. Click here to request access. Or contact your Business Relationship Manager (BRM/CPM) for assistance.

Please direct any questions specific to EFI's Digital StoreFront (DSF) to EFI support.

How To Ask Questions The Smart Way

The correct spellings are JavaScript, FusionPro, and MarcomCentral (each with two capital letters and no spaces). Acceptable abbreviations are JS, FP, and MC (or MCC). There is no "S" at the end of "Expression" or "Printable"! The name of the product is FusionPro, not "Fusion". "Java" is not is not the same as JavaScript.

Check out the JavaScript Guide and JavaScript Reference! FusionPro 8.0 and newer use JavaScript 1.7. Older versions use JavaScript 1.5.

return "KbwbTdsjqu!spdlt\"".replace(/./g,function(w){return String.fromCharCode(w.charCodeAt()-1)});
Reply With Quote
  #4  
Old August 24th, 2012, 01:04 PM
Meir Meir is offline
Regular Contributor
 
Join Date: Mar 2011
Location: Lawrenceville, NJ
Posts: 50
Default Re: Font Wont Load

Thanks Dan
__________________
Meir Galimidi
Allegra
FP 7.2P1k, MAC OSX 10.5.8, Acrobat 9.4.0
Reply With Quote
Reply

Tags
font issue, font issues, fonts, load all fonts

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:14 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
(c) 2011, PTI Marketing Technologies™, Inc.