Thread: datamatrix help
View Single Post
  #5  
Old June 4th, 2018, 06:28 PM
Dan Korn's Avatar
Dan Korn Dan Korn is offline
FusionPro Senior Engineer / Forum Moderator
 
Join Date: Aug 2008
Location: Chicago, IL
Posts: 4,671
Default Re: datamatrix help

Quote:
Originally Posted by Mike Edwards View Post
Yes, I get that, and it's what I expect, but this code is returning "00" for CurrSheet in every instance. I was hoping someone could tell me if my syntax is wrong or what the problem might be.
Yes, "this" code, as in the only code you've posted so far, won't work.

Did you try using FusionPro.Composition.impositionSheetNumber instead, as I recommended?

Posting the template would probably be helpful than more rounds of back-and-forth like this.
Quote:
Originally Posted by Mike Edwards View Post
Further testing shows that although when I run Validate during rule construction I get the correct value
I don't see how you could possibly know that. First of all, there's no actual page or sheet number at rule validation time; it's just a rule, with no context of where you might be when actually composing.

Second, if you validate the rule you've posted, all you will get are some markup tags that make a DataMatrix barcode, which look something like this:
Code:
<f name="IDAutomationDMatrix"><z newsize="10"><leading newsize="100">AIHPDOCIHK<br>AEMONMCLLK<br>DLLDDDLDLL<br>
How do you know at validation time whether that's the correct value?
Quote:
Originally Posted by Mike Edwards View Post
when the job previews
Preview is a completely invalid test here as well, since you're not imposing the output, you're just previewing a single record, one-up.
Quote:
Originally Posted by Mike Edwards View Post
or is composed, it still shows "00" every time.
Again, how does it "show" this? Are you scanning the barcode? With what scanning device and software?

Perhaps posting a picture of the barcode would give me some idea of what you're talking about. Though as I said, the template would be better.
Quote:
Originally Posted by Mike Edwards View Post
Am I not understanding how this is supposed to work, or is there a bug?
We're not understanding each other, at least.

I'm trying to help. But I don't have your data, or the rest of your template. I don't know what you're seeing in the output, or how you're analyzing it. I can only look at the code you've posted and try to guess as to what's wrong. Please post the template so I can fully analyze the issue.
__________________
Dan Korn
FusionPro Developer / JavaScript Guru / Forum Moderator
PTI Marketing Technologies | Printable | MarcomCentral
LinkedIn

I am a not a Support engineer, and this forum is not a substitute for Support. My participation on this forum is primarily as a fellow user (and a forum moderator). I am happy to provide help and answers to questions when I can; however, there is no guarantee that I, or anyone else on this forum, will be able to answer all questions or fix any problems. If I ask for files to clarify an issue, I might not be able to look at them personally. I am not able to answer private messages, emails, or phone calls unless they go through proper Support channels. Please direct any sales or pricing questions to your salesperson or inquiries@marcom.com.

Complex template-building questions, as well as all installation and font questions or problems, should be directed to FusionProSupport@marcom.com. Paid consulting work may be required to fulfill your template-building needs.

This is a publicly viewable forum. Please DO NOT post fonts, or other proprietary content, to this forum. Also, please DO NOT post any "live" data with real names, addresses, or any other personal, private, or confidential data.

Please include the specific versions of FusionPro, Acrobat, and your operating system in any problem reports or help requests. I recommend putting this information in your forum signature. Please also check your composition log (.msg) file for relevant error or warning messages.

Please post questions specific to the MarcomCentral Enterprise and Web-to-Print applications in the MarcomCentral forum. Click here to request access. Or contact your Business Relationship Manager (BRM/CPM) for assistance.

Please direct any questions specific to EFI's Digital StoreFront (DSF) to EFI support.

How To Ask Questions The Smart Way

The correct spellings are JavaScript, FusionPro, and MarcomCentral (each with two capital letters and no spaces). Acceptable abbreviations are JS, FP, and MC (or MCC). There is no "S" at the end of "Expression" or "Printable"! The name of the product is FusionPro, not "Fusion". "Java" is not is not the same as JavaScript.

Check out the JavaScript Guide and JavaScript Reference! FusionPro 8.0 and newer use JavaScript 1.7. Older versions use JavaScript 1.5.

return "KbwbTdsjqu!spdlt\"".replace(/./g,function(w){return String.fromCharCode(w.charCodeAt()-1)});

Last edited by Dan Korn; June 7th, 2018 at 11:35 AM..
Reply With Quote