MarcomCentral (PTI) and FusionPro User Communities

MarcomCentral (PTI) and FusionPro User Communities (http://forums.pti.com/index.php)
-   Getting Started (http://forums.pti.com/forumdisplay.php?f=18)
-   -   Special characters and UTF-8 (http://forums.pti.com/showthread.php?t=3694)

EricC February 13th, 2014 01:02 PM

Special characters and UTF-8
 
I am working with a data file that is encoded as UTF-8

Special characters appear when I open the data file in Notepad++

For example:
Özmark
Ayazağa Mah
Şişli
İstanbul

When I link this data file to FusionPro, every accented character disappears.

How can I get special characters to appear when composing records?

Dan Korn February 13th, 2014 01:15 PM

Re: Special characters and UTF-8
 
There are three things you need to make sure of:
  1. That the data file has a UTF-8 byte order mark (BOM). FusionPro relies on the BOM to know that the file is UTF-8. Notepad++ should be able to add the BOM if it's not already present.
  2. That you're using a font which supports the Unicode characters.
  3. That the "Limit processing to Latin-1" box on the Advanced tab of the composition settings dialog is NOT checked.
As usual, doing a full composition (not a Preview) and looking in the log (.msg) file will probably give you some idea of what's not working.

jimmyhartington February 18th, 2014 12:12 AM

Re: Special characters and UTF-8
 
In OS X you can use TextWrangler (free) or BBEdit to set the BOM.


All times are GMT -7. The time now is 02:48 AM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
(c) 2011, PTI Marketing Technologies™, Inc.